OldSchoolHack

Registrieren / Anmelden Deutsch

[Report] OSH VisualGui - SetImage Bug und Application


icon [Report] OSH VisualGui - SetImage Bug und Application #1

Anmeldungsdatum: Aug 2008

Beiträge: 2594

Benutzer-Bewertung:

17 positiv
5 negativ
Der String bei SetImage wird falsch generiert:
CPP Code:
  1. pic->SetImage("Application::GetRenderer()->CreateNewTexture(\"C:\\pic.png\")");
2 Ausrufezeichen auf der Falsche stelle und vorne und hinten 2 falsche \.

Und "Application::" Bug.
Muss ja "Application::Instance()->" heißen.
Und da es ja alles in der hpp steht, noch OSHGui:: dazu.
CPP Code:
  1. pic->SetImage(OSHGui::Application::Instance()->GetRenderer()->CreateNewTexture("C:\\pic.png"));


icon #2

Anmeldungsdatum: Aug 2007

Beiträge: 8646

Benutzer-Bewertung:

198 positiv
31 negativ
fixed in der neusten Version
Denk aber dran, dass du die Pfade relativ machen solltest (geht im VisualGui natürlich nicht) oder erst zur Laufzeit zusammenbaust.

greetz KN4CK3R

__________________

Hallo
icon #3

Anmeldungsdatum: Aug 2008

Beiträge: 2594

Benutzer-Bewertung:

17 positiv
5 negativ
Zitat von KN4CK3R
fixed in der neusten Version
Denk aber dran, dass du die Pfade relativ machen solltest (geht im VisualGui natürlich nicht) oder erst zur Laufzeit zusammenbaust.

greetz KN4CK3R
Danke.
Pfade relativ zu der dll/exe?
Ich dill die Bilder eh als Ressourcen mit reincompilieren.
icon #4

Anmeldungsdatum: Aug 2007

Beiträge: 8646

Benutzer-Bewertung:

198 positiv
31 negativ
dann musste eh alles anders machen

greetz KN4CK3R

__________________

Hallo
icon #5

Anmeldungsdatum: Aug 2008

Beiträge: 2594

Benutzer-Bewertung:

17 positiv
5 negativ
Zitat von KN4CK3R
dann musste eh alles anders machen

greetz KN4CK3R
Ich zeige hier nicht wie ich es gemacht habe, ich habe nur den Bug reported.